Python3

Last updated 3 months ago

We currently support Python3.6.6

The following third-party modules can be used in your Python 3 submissions.

# pip3 freeze
asn1crypto==0.24.0
backports-abc==0.5
bcrypt==3.1.4
beautifulsoup4==4.6.0
blinker==1.4
capstone==3.0.4
certifi==2018.1.18
cffi==1.11.5
chardet==3.0.4
click==6.7
cryptography==2.2.2
decorator==4.1.2
dpkt==1.9.1
enum34==1.1.6
Flask==1.0.2
futures==3.1.1
html5lib==0.999999999
idna==2.6
intervaltree==2.1.0
ipaddress==1.0.22
itsdangerous==0.24
Jinja2==2.10
keyring==10.6.0
keyrings.alt==3.0
lxml==4.2.1
Mako==1.0.7
MarkupSafe==1.0
ndg-httpsclient==0.5.0
nose==1.3.7
numpy==1.13.3
olefile==0.45.1
packaging==17.1
pandas==0.23.0
paramiko==2.4.1
pexpect==4.5.0
Pillow==5.1.0
pluggy==0.6.0
psutil==5.4.5
ptyprocess==0.5.2
py==1.5.3
pyasn1==0.4.2
pycparser==2.18
pycrypto==2.6.1
pyelftools==0.24
Pygments==2.2.0
pygobject==3.26.1
pyinotify==0.9.6
PyJWT==1.6.4
PyMySQL==0.8.1
PyNaCl==1.2.1
pyOpenSSL==18.0.0
pypandoc==1.4
pyparsing==2.2.0
pyserial==3.4
PySocks==1.6.8
python-apt==1.6.0
python-dateutil==2.7.3
pytz==2018.4
pyxdg==0.25
requests==2.18.4
scapy==2.4.0
scipy==1.1.0
SecretStorage==2.3.1
singledispatch==3.4.0.3
six==1.11.0
sortedcontainers==2.0.2
ssh-import-id==5.7
tornado==5.0.2
tox==3.0.0
unattended-upgrades==0.1
unicorn==1.0.1
urllib3==1.22
uWSGI==2.0.17
virtualenv==15.1.0
webencodings==0.5
Werkzeug==0.14.1